Code pulled with git from git://github.com/erlang/otp.git with the last commit being

These are Intersection warnings for otp-hipe.

(Only new warnings by Intersection-enabled analysis are listed. Warnings by current public version of Dialyzer are listed here.)

dialyzer -n -q -Wno_improper_lists --apps hipe
cerl_pmatch.erl:338: The variable _ can never match since previous clauses completely covered the type 'binary' | 'cons' | 'literal' | 'tuple'